]> Dogcows Code - chaz/yoink/blobdiff - extra/yoink.ebuild
minor build system changes
[chaz/yoink] / extra / yoink.ebuild
index bad914967638d3f6abc4997bc3381b7ffc81f65c..2bd8d27404400012d10efda432bd9fc0a937ce6b 100644 (file)
@@ -14,7 +14,7 @@ SRC_URI="http://www.dogcows.com/yoink/${P}.tar.bz2
 LICENSE="BSD-2 BSD LGPL-2.1 ZLIB"
 SLOT="0"
 KEYWORDS="amd64 ~ppc x86"
-IUSE="debug profile"
+IUSE="debug double-precision profile threads"
 
 RDEPEND="dev-lang/lua
        media-libs/freealut
@@ -44,14 +44,15 @@ src_prepare() {
 src_configure() {
        egamesconf \
                --disable-dependency-tracking \
-               --with-assetdir="${GAMES_DATADIR}/${PN}" \
                $(use_enable debug) \
-               $(use_enable profile)
+               $(use_enable double-precision) \
+               $(use_enable profile) \
+               $(use_enable threads)
 }
 
 src_install() {
        emake DESTDIR="${D}" install || die "emake install failed"
-       dodoc AUTHORS ChangeLog README TODO
+       dodoc AUTHORS ChangeLog COPYING README TODO
        doman doc/yoink.6
        doicon data/yoink.png
        make_desktop_entry ${PN} Yoink
This page took 0.019972 seconds and 4 git commands to generate.