]> Dogcows Code - chaz/yoink/blobdiff - extra/PKGBUILD
now can create win32 portable packages
[chaz/yoink] / extra / PKGBUILD
diff --git a/extra/PKGBUILD b/extra/PKGBUILD
new file mode 100644 (file)
index 0000000..fed4e99
--- /dev/null
@@ -0,0 +1,31 @@
+# Contributor: Charles McGarvey <onefriedrice@brokenzipper.com>
+pkgname=yoink
+pkgver=@VERSION@
+pkgrel=1
+pkgdesc="Alien-smashing action game"
+arch=('i686' 'x86_64')
+url="http://www.dogcows.com/yoink"
+license=('BSD')
+groups=()
+depends=('libgl' 'libpng' 'libvorbis' 'lua' 'openal' 'sdl')
+makedepends=('boost' 'pkgconfig')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=(http://www.dogcows.com/yoink/$pkgname-$pkgver.tar.bz2)
+noextract=()
+md5sums=('@CHECKSUM@')
+
+build() {
+  cd "$srcdir/$pkgname-$pkgver"
+
+  ./configure --prefix=/usr
+  make || return 1
+  make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
This page took 0.01615 seconds and 4 git commands to generate.