]> Dogcows Code - chaz/yoink/blobdiff - arch/gentoo/yoink.ebuild
more normal configure options for gtk and qt4
[chaz/yoink] / arch / gentoo / yoink.ebuild
index a7394b310cd3deef3130e32b952c103dbd51a76d..16781c7a5343d1113e5205556514e1a01185956c 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI="http://www.dogcows.com/yoink/${P}.tar.bz2
 
 LICENSE="BSD-2 BSD LGPL-2.1 ZLIB"
 SLOT="0"
 
 LICENSE="BSD-2 BSD LGPL-2.1 ZLIB"
 SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
+KEYWORDS="amd64 x86"
 IUSE="debug double-precision gtk qt4 threads"
 
 RDEPEND="dev-lang/lua
 IUSE="debug double-precision gtk qt4 threads"
 
 RDEPEND="dev-lang/lua
@@ -28,15 +28,8 @@ DEPEND="${RDEPEND}
        dev-util/pkgconfig"
 
 src_prepare() {
        dev-util/pkgconfig"
 
 src_prepare() {
-       sed -i \
-               -e "/apps/d" \
-               -e "/pixmap/d" \
-               data/Makefile.am \
-               || die "sed failed"
-       sed -i \
-               -e "/man/d" \
-               doc/Makefile.am \
-               || die "sed failed"
+       sed -i -e "/apps/d" -e "/pixmap/d" data/Makefile.am || die "sed failed"
+       sed -i -e "/man/d" Makefile.am || die "sed failed"
 
        eautoreconf
 }
 
        eautoreconf
 }
@@ -46,9 +39,9 @@ src_configure() {
                --disable-dependency-tracking \
                $(use_enable debug) \
                $(use_enable double-precision) \
                --disable-dependency-tracking \
                $(use_enable debug) \
                $(use_enable double-precision) \
-               $(use_enable gtk) \
-               $(use_enable qt4) \
-               $(use_enable threads)
+               $(use_enable threads) \
+               $(use_with gtk) \
+               $(use_with qt4)
 }
 
 src_install() {
 }
 
 src_install() {
This page took 0.019617 seconds and 4 git commands to generate.