]> Dogcows Code - chaz/yoink/blobdiff - arch/gentoo/yoink.ebuild
mesh and other random adjustments
[chaz/yoink] / arch / gentoo / yoink.ebuild
index 16781c7a5343d1113e5205556514e1a01185956c..6e167d0bf3daa0424232b349e463145f3e0104e8 100644 (file)
@@ -4,17 +4,17 @@
 
 EAPI=2
 
-inherit autotools eutils games
+inherit eutils games
 
 DESCRIPTION="Alien-smashing action game"
 HOMEPAGE="http://www.dogcows.com/yoink/"
-SRC_URI="http://www.dogcows.com/yoink/${P}.tar.bz2
+SRC_URI="http://www.dogcows.com/yoink/chrome/site/${P}.tar.bz2
        http://eng.utah.edu/~mcgarvey/yoink/${P}.tar.bz2"
 
 LICENSE="BSD-2 BSD LGPL-2.1 ZLIB"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE="debug double-precision gtk qt4 threads"
+IUSE="debug double-precision gtk hotload qt4 threads"
 
 RDEPEND="dev-lang/lua
        media-libs/libpng
@@ -22,30 +22,26 @@ RDEPEND="dev-lang/lua
        media-libs/libvorbis
        media-libs/openal
        virtual/glu
-       virtual/opengl"
+       virtual/opengl
+       gtk? ( x11-libs/gtk+:2 )
+       qt4? ( !gtk? ( x11-libs/qt-core:4 ) )"
 DEPEND="${RDEPEND}
        dev-libs/boost
        dev-util/pkgconfig"
 
-src_prepare() {
-       sed -i -e "/apps/d" -e "/pixmap/d" data/Makefile.am || die "sed failed"
-       sed -i -e "/man/d" Makefile.am || die "sed failed"
-
-       eautoreconf
-}
-
 src_configure() {
        egamesconf \
                --disable-dependency-tracking \
                $(use_enable debug) \
                $(use_enable double-precision) \
+               $(use_enable hotload) \
                $(use_enable threads) \
                $(use_with gtk) \
                $(use_with qt4)
 }
 
 src_install() {
-       emake DESTDIR="${D}" install || die "emake install failed"
+       emake DESTDIR="${D}" install_man=no install || die "emake failed"
        dodoc AUTHORS COPYING README TODO
        doman doc/yoink.6
        doicon data/yoink.png
This page took 0.018541 seconds and 4 git commands to generate.