]> Dogcows Code - chaz/yoink/blob - extra/yoink.ebuild
big batch of changes
[chaz/yoink] / extra / yoink.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit autotools eutils games
8
9 DESCRIPTION="Alien-smashing action game"
10 HOMEPAGE="http://www.dogcows.com/yoink/"
11 SRC_URI="http://www.dogcows.com/yoink/${P}.tar.bz2
12 http://eng.utah.edu/~mcgarvey/yoink/${P}.tar.bz2"
13
14 LICENSE="BSD-2 BSD LGPL-2.1 ZLIB"
15 SLOT="0"
16 KEYWORDS="amd64 ~ppc x86"
17 IUSE="debug double-precision gtk qt4 threads"
18
19 RDEPEND="dev-lang/lua
20 media-libs/freealut
21 media-libs/libsdl[opengl]
22 media-libs/libvorbis
23 media-libs/openal
24 media-libs/sdl-image[png]
25 virtual/opengl"
26 DEPEND="${RDEPEND}
27 dev-libs/boost
28 dev-util/pkgconfig"
29
30 src_prepare() {
31 sed -i \
32 -e "/apps/d" \
33 -e "/pixmap/d" \
34 data/Makefile.am \
35 || die "sed failed"
36 sed -i \
37 -e "/man/d" \
38 doc/Makefile.am \
39 || die "sed failed"
40
41 eautoreconf
42 }
43
44 src_configure() {
45 egamesconf \
46 --disable-dependency-tracking \
47 $(use_enable debug) \
48 $(use_enable double-precision) \
49 $(use_enable gtk) \
50 $(use_enable qt4) \
51 $(use_enable threads)
52 }
53
54 src_install() {
55 emake DESTDIR="${D}" install || die "emake install failed"
56 dodoc AUTHORS ChangeLog COPYING README TODO
57 doman doc/yoink.6
58 doicon data/yoink.png
59 make_desktop_entry ${PN} Yoink
60 prepgamesdirs
61 }
This page took 0.034596 seconds and 4 git commands to generate.