]> Dogcows Code - chaz/yoink/blob - build/arch/gentoo/yoink.ebuild
further implementing runloop support
[chaz/yoink] / build / arch / gentoo / yoink.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6 inherit eutils games
7
8 DESCRIPTION="Alien-smashing action game"
9 HOMEPAGE="http://www.dogcows.com/yoink"
10 SRC_URI="ftp://ftp.dogcows.com/yoink/${P}.tar.bz2"
11
12 LICENSE="BSD-2 BSD LGPL-2.1 ZLIB"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc x86"
15 IUSE="debug double-precision gtk hotload qt4 threads"
16
17 RDEPEND="dev-lang/lua
18 media-libs/libpng
19 media-libs/libsdl[opengl]
20 media-libs/libvorbis
21 media-libs/openal
22 virtual/glu
23 virtual/opengl
24 gtk? ( x11-libs/gtk+:2 )
25 qt4? ( !gtk? ( x11-libs/qt-core:4 ) )"
26 DEPEND="${RDEPEND}
27 dev-libs/boost
28 dev-util/pkgconfig"
29
30 src_configure() {
31 egamesconf --disable-dependency-tracking \
32 --install-icon=no \
33 --print-instructions=no \
34 $(use_enable debug) \
35 $(use_enable double-precision) \
36 $(use_enable hotload) \
37 $(use_enable threads) \
38 $(use_with gtk) \
39 $(use_with qt4)
40 }
41
42 src_install() {
43 emake DESTDIR="${D}" install || die "Install failed"
44 dodoc AUTHORS COPYING README TODO || die "Install docs failed"
45 doicon data/yoink.png || die "Install icon failed"
46 make_desktop_entry yoink Yoink || die "Install destop entry failed"
47 prepgamesdirs
48 }
This page took 0.032206 seconds and 4 git commands to generate.