]> Dogcows Code - chaz/yoink/blob - arch/gentoo/yoink.ebuild
more normal configure options for gtk and qt4
[chaz/yoink] / arch / gentoo / yoink.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit autotools eutils games
8
9 DESCRIPTION="Alien-smashing action game"
10 HOMEPAGE="http://www.dogcows.com/yoink/"
11 SRC_URI="http://www.dogcows.com/yoink/${P}.tar.bz2
12 http://eng.utah.edu/~mcgarvey/yoink/${P}.tar.bz2"
13
14 LICENSE="BSD-2 BSD LGPL-2.1 ZLIB"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="debug double-precision gtk qt4 threads"
18
19 RDEPEND="dev-lang/lua
20 media-libs/libpng
21 media-libs/libsdl[opengl]
22 media-libs/libvorbis
23 media-libs/openal
24 virtual/glu
25 virtual/opengl"
26 DEPEND="${RDEPEND}
27 dev-libs/boost
28 dev-util/pkgconfig"
29
30 src_prepare() {
31 sed -i -e "/apps/d" -e "/pixmap/d" data/Makefile.am || die "sed failed"
32 sed -i -e "/man/d" Makefile.am || die "sed failed"
33
34 eautoreconf
35 }
36
37 src_configure() {
38 egamesconf \
39 --disable-dependency-tracking \
40 $(use_enable debug) \
41 $(use_enable double-precision) \
42 $(use_enable threads) \
43 $(use_with gtk) \
44 $(use_with qt4)
45 }
46
47 src_install() {
48 emake DESTDIR="${D}" install || die "emake install failed"
49 dodoc AUTHORS COPYING README TODO
50 doman doc/yoink.6
51 doicon data/yoink.png
52 make_desktop_entry ${PN} Yoink
53 prepgamesdirs
54 }
This page took 0.036958 seconds and 5 git commands to generate.