]> Dogcows Code - chaz/yoink/blob - arch/gentoo/yoink.ebuild
further implementing runloop support
[chaz/yoink] / arch / gentoo / yoink.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit eutils games
8
9 DESCRIPTION="Alien-smashing action game"
10 HOMEPAGE="http://www.dogcows.com/yoink/"
11 SRC_URI="http://www.dogcows.com/yoink/chrome/site/${P}.tar.bz2
12 http://eng.utah.edu/~mcgarvey/yoink/${P}.tar.bz2"
13
14 LICENSE="BSD-2 BSD LGPL-2.1 ZLIB"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="debug double-precision gtk hotload qt4 threads"
18
19 RDEPEND="dev-lang/lua
20 media-libs/libpng
21 media-libs/libsdl[opengl]
22 media-libs/libvorbis
23 media-libs/openal
24 virtual/glu
25 virtual/opengl
26 gtk? ( x11-libs/gtk+:2 )
27 qt4? ( !gtk? ( x11-libs/qt-core:4 ) )"
28 DEPEND="${RDEPEND}
29 dev-libs/boost
30 dev-util/pkgconfig"
31
32 src_configure() {
33 egamesconf \
34 --disable-dependency-tracking \
35 $(use_enable debug) \
36 $(use_enable double-precision) \
37 $(use_enable hotload) \
38 $(use_enable threads) \
39 $(use_with gtk) \
40 $(use_with qt4)
41 }
42
43 src_install() {
44 emake DESTDIR="${D}" install_man=no install || die "emake failed"
45 dodoc AUTHORS COPYING README TODO
46 doman doc/yoink.6
47 doicon data/yoink.png
48 make_desktop_entry ${PN} Yoink
49 prepgamesdirs
50 }
This page took 0.030348 seconds and 4 git commands to generate.